Tomcat Unsupported major.minor version 51.0 에러 해결 방법

2016.01.05 17:51etc/error

에러 메시지 중에서

 


Unsupported major.minor version 51.0 (unable to load class com.xxx.xxx.xxx.xxxxx)

 


이런 메시지가 보인다면

 


tomcat 6 에서 jdk 1.7로 컴파일된 프로젝트를 실행시켜서 나는 애러이다.

 


Tomcat6에서는 JDK1.7 버전을 지원하지 않는다고 한다. 

 

Tomcat를 7버전으로 올리거나

 

jdk 컴파일 버전을 1.6으로 내려야 하는데

 

jdk 컴파일 버전을 1.6으로 내리는 것은 추천하지 않는다.

 

기존 1.7로 컴파일 된 프로젝트를 1.6으로 내릴 경우

 

간혹 케스팅 문제나 기타 문제로 인하여 오류가 날 확률이 있기 때문이다.

 

 

Tomcat7을 사용하여 에러를 해결하세요 ㅎㅎ

 



이것도 모르고 삽질을 ......ㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠㅠ

 

 

 

도움이 되셨다면 공감을 부탁드립니다. ^^